Monday, January 30, 2006

Beware the Asus P5GD1-VM motherboard!

In a nutshell, I replaced this mofo of a mobo because of one simple problem: it could not boot from an IDE CD-ROM drive, so I could not fix my computer. I thought there was something defective with my motherboard, so I replaced with with exactly the same one--and the new one had exactly the same problem.

However, there is exactly one scenario in which I was able to boot a CD. I was able to boot my Windows 2000 CD correctly under the following conditions:
  • The CD-ROM drive must be on the primary IDE channel (it worked as Slave for me).
  • In the BIOS, the "IDE mode" option must be set to "Compatible" (not "Enhanced", which is the default). You can tell when you are in "Compatible" mode because the BIOS screen shows only "Primary" and "Secondary", with no 3rd IDE pair.
Now, there is one tricky thing you have to deal with. "Compatible" mode changes the definition of "Primary". There are two IDE connectors on the motherboard. In Compatible mode, "Primary" means the upper IDE connector. However, in Enhanced mode, "Primary" is the lower IDE connector. Therefore, when you switch modes, you must physically swap the upper and lower connectors!

There are a couple more caveats.
  1. I could not boot any Linux CD correctly under any circumstances. I tried Damn Small Linux, Knoppix and the Kubuntu Live CD (I used the current version of each CD as of Jan. 20, 2006). Even if the boot process starts, the Linux CD will be unable to mount the CD filesystem, or it will crash or freeze during startup. You can boot Kubuntu from an external USB 2.0 drive, but not DSL or Knoppix. I also tried a RIP Linux floppy disk, and it was unable to see the CD drive.
  2. The Windows 2000 CD will not see the hard drive unless it is on the Primary IDE channel. So put your HDD on Primary Master and your CD on Primary Slave. Kubuntu could not see the hard drive either when I tried it, but I don't remember what configuration I was using at the time.


At 3/15/2006 12:52 PM, Anonymous Anonymous said...

huh? I have the same mobo and hve not have any problems with it. I installed kanotix to try it out, everything worked including 6 channel (at least alsamixer-gui had it). The only thing that didn't work was the standby. Im going to put ubuntu64 on it now.

At 3/15/2006 2:53 PM, Blogger Qwertie said...

Wow... I guess you're lucky. With the right settings I actually did get Linux installed with IDE devices, however; see this post:

At 3/12/2009 1:50 AM, Anonymous Anonymous said...

Dear just copy IT8211 raid driver into floppy and insert it in floppy drive. Now boot your computer from cd rom. Always connect your hard drive with PCI IDE connector. And CD Rom with IDE connector.

At 3/12/2009 6:18 PM, Blogger Qwertie said...

If only I had your help three years ago...


Post a Comment

<< Home